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Chapter 1: Required Programs

The following is a list of programs needed to start working, links to find them
online, and the steps necessary to configure the individual programs.

Audacity

Audacity is a basic audio editing program. It can be found online at
http://audacity.sourceforge.net/, and is compatible with both PC and MAC. After
installing Audacity, you must install the LAME encoder in order to export MP3s.
Instructions on how to location and install the LAME encoder can be found on
Audacity’s Help Wiki at the following link:
http://manual.audacityteam.org/help/manual/man/faq installation and plug ins
html#lame

These instructions are reprinted below for your convenience.
Windows

1. Go to the download page
Left-click this link, do not right-click.

2. In"For Audacity on Windows", left-click the link Lame
v3.99.3 for Windows.exe and save the file anywhere on
your computer.

3. Double-click "Lame v3.99.3 for Windows.exe" to launch it
(you can safely ignore any warnings that the "publisher
could not be verified").

4. Follow the Setup instructions to install LAME for Audacity,
making sure not to change the offered installation location
of "C:\Program Files\Lame for Audacity" (or "C:\Program
Files (x86)\Lame for Audacity" on a 64-bit version of
Windows).

You should now be able to export MP3s without any further configuration,
choosing File > Export... then selecting "MP3 Files" in the File Export Dialog.

Troubleshooting

Occasionally, there can be .dll conflicts on the computer. Try right-clicking

this alternative 3.98.4 build of lame_enc.dll. Choose "Save Target As" or "Save
Link As" and save it to "C:\Program Files\Lame for Audacity" or "C:\Program
Files (x86)\Lame for Audacity" according to where you installed LAME



http://www.gaclrecords.org.uk/software/lame_enc.dll
http://manual.audacityteam.org/help/manual/man/file_export_dialog.html
http://manual.audacityteam.org/help/manual/man/file_menu.html#Export...
http://lame1.buanzo.com.ar/
http://manual.audacityteam.org/help/manual/man/faq_installation_and_plug_ins.html#lame
http://manual.audacityteam.org/help/manual/man/faq_installation_and_plug_ins.html#lame
http://manual.audacityteam.org/help/manual/index.html
http://audacity.sourceforge.net/

previously. Accept any prompts to replace the old file with the new one. Then
try exporting an MP3 again.

If there are still problems, they will likely be due to a conflict with Audacity still
trying to detect the path to an older lame_enc.dll file. To correct this:

1. Ensure there are no older versions of lame_enc.dll in any
locations where Audacity detects it, namely:

= C:\Program Files\Lame for Audacity (where the
installer puts the new .dll)
= the Audacity installation folder (usually C:\Program

Files\Audacity) or in the Plug-Ins folder inside that
2. Exit Audacity and navigate to the 1.3 preferences .cfg file
at:

=  Windows 2000/XP: Documents and Settings\<user
name>\Application Data\Audacity\audacity.cfg
=  Windows Vista/7: Users\<user
name>\AppData\Roaming\Audacity\audacity.cfg.
3. Open audacity.cfg in a text editor such as Notepad, and
delete the two lines starting with:
= [MP3]
MP3LibPath=
4. Save the changes to audacity.cfg and restart Audacity

In order to see audacity.cfg, you may need to set the operating
system to show hidden files and folders. See instructions
for Windows 7 and Windows versions before 7.

Note that the above four steps will remove old paths to lame_enc.dll for
Audacity version 1.3 and later only. If you still use (or have ever used) Audacity
1.2, that version will continue to look for the .dll in the location stored in its own
Preferences setting.

Merely exiting Audacity and deleting audacity.cfg will not remove
old paths to lame_enc.dll for 1.3 if you have ever previously used
a 1.2 version. In that case Audacity 1.3 and later would still look
up the path from the 1.2 Preferences setting.

Mac OS X

On OS X 10.6 or later, Administrative (and occasionally, root)
permissions may be needed on some machines to read the LAME
library the installer places in /usr/local/lib/audacity.


http://www.bleepingcomputer.com/tutorials/tutorial62.html
http://www.bleepingcomputer.com/tutorials/tutorial151.html

In case of difficulty, please download the zip version

“Lame_Library v3.98.2_for_Audacity_on_OSX.zip" from "Alternative zip

download for Lame 3.98.2" below and follow the instructions.

= Installer

1. Go to the LAME download page.

2. Download Lame Library v3.98.2 for Audacity on
OSX.dmg.

3. When you have finished downloading, double-click the
.dmg to mount it, then go to the Finder (in Safari, the
"Lame Library v3.98.2 for Audacity" virtual disk image will
be extracted and mounted automatically after
downloading).

4. Double-click "Lame Library v3.98.2 for Audacity.pkg"; the
standard OS X Installer will start

5. Click through the steps in the Installer, accepting the
defaults in all cases; this will install the LAME binary
"libmp3lame.dylib” in /usr/local/lib/audacity.

6. Audacity should detect LAME automatically when you

export as MP3. If Audacity cannot find LAME:

1. Click Audacity > Preferences then choose
"Libraries" on the left.

2. Click "Locate..." under "MP3 Export Library", then
"Browse..." in the "Locate Lame" dialog.

3. The "Where is libmp3lame.dylib?" window will open
at /usr/local/lib/audacity; select "libmp3lame.dylib",
click "Open" then "OK" and "OK".

= Alternative zip download for Lame 3.98.2

1.

2.

Download http://lamel.buanzo.com.ar/Lame_Library v3.9
8.2_for_Audacity_on_OSX.zip

Extract the contents of the zip to a folder called
"Lame_Library v3.98.2 for_Audacity_on_OSX" anywhere
you have full permissions (such as your Desktop) then
follow the instructions at steps 6.1 to 6.3 above to locate
"libmp3lame.dylib" using the Libraries Preferences. This is
a good solution if Audacity does not recognize
libmp3lame.dylib when installed to /usr/local/lib/audacity.

You should now be able to export MP3s without any further configuration,


http://lame1.buanzo.com.ar/Lame_Library_v3.98.2_for_Audacity_on_OSX.zip
http://lame1.buanzo.com.ar/Lame_Library_v3.98.2_for_Audacity_on_OSX.zip
http://manual.audacityteam.org/help/manual/man/preferences.html
http://lame1.buanzo.com.ar/

choosing File > Export... then selecting "MP3 Files" in the File Export Dialog.

In case of difficulty, or if you have an older version of Audacity, please view
our detailed instructions on the Audacity Wiki.



http://wiki.audacityteam.org/
http://wiki.audacityteam.org/wiki/Lame_Installation#Mac_Instructions
http://manual.audacityteam.org/help/manual/man/file_export_dialog.html
http://manual.audacityteam.org/help/manual/man/file_menu.html#Export...

Text Wrangler/jEdit

Text Wrangler and jEdit are text/HTML editors required for editing the content of
pages on PennSound. Text Wrangler should be used on MAC computers, and jEdit
on PCs.

TEXT WRANGLER

Text Wrangler can be downloaded from the following link:
http://www.barebones.com/products/textwrangler/. To configure Text Wrangler
initially, open the program, and on the top bar, click File>Open from FTP/SFTP

Server. Fill in the information as follows:
# TextWrangler File Edit Text View Search Window # # Help

Q6 FTP Browser 1
Not connected. Bookmarks: @
(not col Server: writing.upenn.edu @
{ [ srTe |
Name | | Kind

User: boruszak

Password: ssssssss

(" cancel ) ( Connect )

Show items starting with “."

Use your Writing Server username/password, but make sure that the SFTP box is
clicked. After connecting for the first time, you will be in your home directory. In
the Navigation drop-down box, return to the earliest directory,
“writing.upenn.edu.” From there click the (case-sensitive) directories in the


http://www.barebones.com/products/textwrangler/

following order:

www > data > writing > pennsound

Once in the “pennsound” directory, click the drop down navigation bar and choose
“Add Bookmark.” Name your bookmark “PennSound.” Now, upon opening Text
Wrangler and choosing “Connect to FTP/SFTP Server,” you will be able to choose
the “PennSound” bookmark (see picture above), saving your credentials and
bringing you immediately to the PennSound directory on the writing server.

jEdit

jEdit can be downloaded from the following link: http://www.jedit.org/index.php?
page=download. To configure jEdit, open the program and select Plugins>Plugin
Manager. Under the “Install” tab, check the box next to “FTP” and hit the install
button. Close the Plugin Manager.

Now, under the Plugins menu, navigate to “FTP” and select “Open from Secure FTP
Server.” Fill out the information as follows:

[ 42 Connect to Secure FTP Server [ér
Remate host: |writing.upenn.edu:22 "'|
User name: |bnrusza|~t v|
Password: |uu--n |
Private key:. | "'|U

[ ] Connect using proxy

Save Passwaord -these are stored in a file that is difficult, but not impossible, to read.

Ok Cancel

Substitute your own username and password. Click OK, and you will connect to
the server. In the new menu, look for the icon of the folder on the left, with the
words sftp://yourusername next to it. Click that folder to navigate to the main
directory. Then navigate to www > data > writing > pennsound. Now click the
“Favorites” tab at the top of this window, and select “Add to Favorites.” Now every
time you open jEdit, you can simply select File > Open, and connect to the server
via the “Favorites” tab.


http://www.jedit.org/index.php?page=download
http://www.jedit.org/index.php?page=download

Fetch/Filezilla

Fetch and Filezilla are file transfer clients used to connect to the writing server in
order to upload complete files. This feature is used almost exclusively in order to
upload author permissions to the writing server. Fetch is used on MACs, while
Filezilla is used on PCs.

Fetch
Fetch can be downloaded from the following link: http://fetchsoftworks.com/. In

order to configure Fetch to connect to the writing server, open the program and
fill in the log in information as follows:

~Name Hostname: |writing.upenn.edu |@ et

Username: !boruszak |

Connect using: [ SFTP M

E’ Enable encryption

Password: Ioouuluml I

"1 Add to keychain

)
® ( Cancel ) f'ﬁlmrlu:l-)

Substitute your own writing server username/password. Once connected, click
the “Path” button, and choose the “/” folder, as highlighted below:


http://fetchsoftworks.com/

writing.upenn.edu

4 boruszak
=] [dhome

Kind | Size | Date

./
| ba — , Document 9.6 KB 5/8/12
[ bai Rwriting.upenn.edu | Document 33 bytes 1/29/10
il‘. .bas Document 265 bytes 1/29/10
| bashrc Document 473 bytes 1/29/10
G LBMacs Document 515 bytes 1/29/10
[ .mozilla Folder - 1/29/10
I_.LI .zshre Document 638 bytes 1/29/10

From there, navigate the (case-sensitive) directories as follows:
www > data > writing > pennsound

Then click the “Shortcuts” button on the top Finder bar. Choose “New Shortcut”
and rename your connection “PennSound.”

Now, upon starting Fetch, you can click the heart-shaped button next to
“Hostname” in the connection box, choose PennSound, and automatically connect
to the PennSound folder of the writing server.

Filezilla

Filezilla can be downloaded from the following link: http://filezilla-project.org/.
Once downloaded, open Filezilla, and select File > Site Manager. Fill out the
window as follows:



http://filezilla-project.org/

r R
Site Manager @
S i General |.ﬂ.d'u'anr_ed | Transfer Settings I Charsetl
Ly My Sites
.-L Mew site Host: writing.upenn.edu Port: | 22|
Protocol; [SFI'P' - 55H File Transfer Protocol v]
Logon Type: [Nurmal v]
Lser: boruszak
Password:; eesssses
Account: ’
Comments:
[ Mew Site ] [ Mew Folder ] i
I Mew Bookmark ] [ Rename ]
[ Delete ] [ Copy. ]
[ Connect ] [ (0] 4 ] [ Cancel ]
L

Click “OK” to connect to the server. Filezilla splits the directories into two halves of
the window. The left side is your computer, and right is the server to which you
are connected. Using the right side for the server, click the folder icon with a “/”
next to it—the highest one in the file tree. The bottom window will change. From
here, navigate the folders to www > data > writing > pennsound. Once here, click
the “Bookmarks” tab at the top of the window, and select “Add Bookmark.” In the
“Name” box, write “PennSound.”

Now, everytime you open the program, you only need to select Bookmarks >
PennSound.



SecureCRT

SecureCRT is a program that allows you to create, convert, and delete pages from
the writing server. It is required only for PC users, and MACs use the native
“Terminal” program. Instructions on how to use both SecureCRT and Terminal are
included in Chapter 5.2: How to Create a Page.

SecureCRT is a licensed program, and all Penn Key owners can download the
program from Penn Computing’s Software page:

http: //www.upenn.edu/computing/pennconnect/about.html. A valid Penn Key
and password are required to download the program.

Terminal is ready to use from the get-go, but SecureCRT requires a little
configuration. MAC users can skip the next section.

Once Secure CRT is downloaded, open the program. Click File > Connect, and a
new window will appear. In this window, there are a number of icons at the top.

Click the third from the left: New Session. A program wizard will open.

Change the protocol to SSH2 and click “Next.” Fill out the next window as follows:

Mew Session Wizard @

What is the name or IP address of the remote host?

The user name can be left blank.

Hostname: writing.upenn. edu

Part: 22

Eirewall: [Nnne -
Username: boruszak|

e i)

b

Use your own username. Click Yes, and on the next screen click “Finish.” Now, in
the list of sessions, find “writing.upenn.edu” and double-click it to connect. Enter
your password and select “Save Password” for future use.


http://www.upenn.edu/computing/pennconnect/about.html

Handbrake

Handbrake is a program used to rip video files from DVDs, and convert video files
to the correct formats. It is compatible with both MACs and PCs. Instructions on
using Handbrake can be found in Chapter 3.3.

Handbrake is free to download, and can be found at the following link:
http://handbrake.fr/.

iTunes

iTunes is an MP3 program that you are most likely already familiar with. It is used
to quickly edit metadata on audio recordings. It is compatible with both MACs and
PCs, and in fact is native to OSX. If you don’t already have iTunes, you can
download it from Apple for free at the following link:
http://www.apple.com/itunes/.



http://www.apple.com/itunes/
http://handbrake.fr/

Chapter 2: Audio on PennSound

2.1: Audio Standards

In the interest of small file size for easy streaming and downloading, Audio files on
PennSound generally follow these standards:

e MONO Sound
* 128 kbps bit rate
* 44.1 kHz (44100 Hz) sample rate

Of these three, the only absolute requirement is the 44.1 kHz sample rate
requirement. The program that streams files on PennSound is incompatible with
other sample rates.

2.2: Configuring Audacity

Before using Audacity for the first time, please configure the program to match
PennSound’s audio standards. Audacity will save these settings, so after they have
been configured the first time, you won’t have to worry about them again. Please
bear in mind though, anytime you install Audacity on a new computer, or open the
program under a new account on the same computer, you MUST reconfigure these
settings.

Start by going to the Preferences menu (on MACs this is the Finder Bar’s Audacity
> Preferences, and on PC’s it is [---]).



000 Audacity
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N

The first tab will be the Audio /0 section, as seen above. In this tab, you will set:

1. Recording Device. If you will be using this computer to digitize cassettes,
you must change this option from “Built-in Microphone” to “Built-in Input.”

2. Channels. Set to mono by default, but please confirm that this is the case.

3. Software Playthrough. Check the box next to this option in order to hear the
audio as Audacity plays it.

Next click the “Quality” tab.



000 Audacity
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BN

Here, confirm that the default sample rate is set to 44100 Hz, and change the
“Default Sample Rate” to 16 bit.

Click “OK” and you're all set to use Audacity!

2.3: Digitizing Cassettes

Digitizing cassette tapes in one of the most common activities at PennSound, and
luckily it is also one of the easiest. Hopefully you're familiar with the technology of
the audio cassette, but just in case you aren’t, let’s go over the basics.



Cassettes look like the picture above. Depending on how well they are labeled,
they should have information about the recording written either on the tape’s
case, or on the case itself. Cassettes have both an “A” side and a “B” side, generally
the beginning of a reading will be found on the A side of the tape. In the center of
this image, you will see a spool of round tape—in this image the tape is fully
rewound, and will begin playing from the start of side A. When this side is down,
you will be able to see the tape on the right side...and when flipped around, it will
once again look like the image above, with a fully rewound B side.

Insert the tape in the cassette player, with the A side facing you. Hit the rewind
button to make sure the tape will play from the beginning. When you are ready to
start, hit the record button in Audacity (it looks like a big red circle), then hit the
play button on the cassette player. Soon you will see the visualization of the wave
form materialize as the tape plays.

TROUBLESHOOTING:

Ifyou don’t hear audio, return to Chapter 2.2 to check that “Software Playthrough”
is selected. If you don’t see a wave visual, first check that the cassette player is
properly connected to the computer. Next check the “Audio 1/0” settings in Chapter
2.2, and confirm that the correct recording device is selected.

Now Audacity should look like the following image:
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On the top toolbar, you’ll see images of a speaker and a microphone, with dials
next to them. The speaker is your system audio, so keep it set to a mid-level. If you
turn it up or down, it will not affect the recording of the track.

The Microphone dial represents the input volume of the recording. When a
recording begins, watch this volume, so as to insure a quality recording. Increase
and decrease the input level as needed. Your goal is create a clear, audible
recording, and visually the wave forms peaks should stay between the 0.5 and
-0.5 marks on the left side of the screen.

TIP:

Sometimes background static or tape deterioration will make the recording semi-
inaudible. In this case, just try to get the best recording that you can. If you have
access to a mixing board, you can play with the bass/treble/pitch, increasing the
bass while cutting the pitch and treble. This often erases the static sound, and works
better for men’s voices than women's.

Listen to the tape the whole way through. In many cases, the recording will
continue to both sides of the tape. When this happens, let the tape finish the side it
is on. Allow Audacity to continue recording. Flip the tape, and press play on the
cassette player. Make a note to yourself of when the tape flipped sides.

When the recording is finished, hit the stop button on Audacity. Delete any blank
sound at the very end of the recording (this should be a flat line visually, and
represents the time in between when the tape finished, and when you hit the stop



button). Return to the point where the tape changed sides (if applicable), and
deleted the blank noise from between the two sides. Very rarely will the tapes
continue directly from where they are—if they do, then match up the recording to
make one seamless transition, otherwise the recording is fine as is. Finally, go to
the beginning of the recording, and delete the blank noise there (this represents
the time between when you hit play on Audacity and play on the cassette player).

Now, go to File > Export as MP3

Name the file following the PennSound naming conventions (Chapter 2.7 below).
For your convenience, set the save location as your desktop. Click “Save.” A box
will pop up asking you to enter metadata information—ignore this and hit OK
(metadata will be set later using iTunes, and is discussed in Chapter 2.6)

Congratulations! You have just digitized a cassette.

TIP:

Sometimes a single tape will have multiple readings on it. Don’t fret! Just record the
whole tape as instructed, and keep notes about who is reading, and when the
recordings change. Once the entire tape has been digitized in Audacity, segment the
recording from the last reading to the first (instructions on segmenting follow in
Chapter 2.5).

2.4: Ripping Audio from Video Files

Occasionally you will get a recording that exists only in video form, but you’ll need
to extract the audio from that recording. The easiest way to do this is to use a MAC
with Garageband installed.

Begin by downloading the video recording to your desktop. Change the extension
of the file from .mov (or .mp4, .m4v, .flv, etc.) to .mp3. A dialog box will appear—

click the box that says “Use .mp3”. You will see the icon change from a thumbnail

of the video to an unidentified audio file.

Open Garageband, and choose “New Project.” Close the piano box that appears.
Drag your new .mp3 file to the far left sidebar. A dialog box will appear that says
“Importing Files,” and when finished, the program should look like this:



® G File Edit Track Control Share Window Help

In the Finder bar, click Share > Export Song to Disk.

In the box that appears, click the “Compress Using” drop-down box, and choose
“MP3 Encoder.” Click Export, and in the box that appears, save your file with any
name, and confirm that the extension is “.“mp3”. If not, change it to this manually.
Save to your desktop.

After exporting, change the original file’s extension back what it previously was
(.mov, .mp4, etc.), and rename the newly created MP3 following PennSound’s
filename guidelines.

2.5: Segmenting Audio

In order to segment audio, begin by opening the track in Audacity. This can be
done either by dragging the track’s icon into Audacity, or by clicking File > Open,
and choosing the mp3. Press the “Play” button and start listening to the track.

At PennSound, we segment introductions, individual poems, Q&A sessions, and
discussions. Remarks before and after poems are included in the poem’s track, as
long as they are under two minutes. Any remarks over two minutes should be
segmented into their own track.

Once you have listened through what will become the individual track, hit the
“Stop” button.



NOTE: If you hit the “Pause” button, instead of the “Stop” button, you will not be able
to edit the track, so be sure to use the “Stop” button!

Your cursor will freeze at its current location on the audio timelines when you
press the “Stop” button. If you need to move the cursor to another location for the
end of the track, just click that spot in the timeline. In the picture below, you can
see the cursor at the 41 second mark.
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Project rate: 44100 | [Cursor: 0:40.992481 min:sec [Snap-To Off]

Next, click Edit > Select > Track Start to Cursor. This will highlight the track from
the beginning to the placement of your cursor. Click Edit > Cut, or ctrl+c (38+c on
MACs). Open a new Audacity window by clicking File > New, and in this new
window paste the track (Edit > Paste; crtl+v for PC, 38 +v for MAC).

To export the track, click File > Export Track as MP3. Name the first file “01”, and
choose the desktop as your save location. After clicking “Save,” leave the metadata
fields blank in the next window and click “OK.”

Repeat this process for each remaining track in the recording. Name each track in
ascending numerical order, keeping a “0” before each number 1 through 9 (ie,
name the tracks “02”, “03”, “04”...”10”, “11”). Open Notepad/Text Edit, and keep




track of each track number and title name in order to label the track easily later.

FYI: The reason tracks are labeled “01” instead of “1” is due to the way computers
list numbers. If tracks were labeled without the “0” in front, the computer would list
10 through 19 after “1” and before “2”. That is, the order would be: 1, 10, 11, 12, 13,
14, 15,16,17,18, 19, 2, 20, 21, 22 etc. Using the “0” will save you a headache at this
point in the process, and will be required later on (see Chapter 2.7 on naming files),
so get used to using it right away!

2.6: Setting Metadata

When you have your tracks ready, open them in iTunes and locate them in your
library. They will be listed with their current filename if they didn’t have metadata
previously associated with them. If you segmented your audio in the last chapter,
then they will be named “01”, “02”, “02”, etc.

To edit the metadata on an individual track, right-click the track (on MACs this is
accomplished by holding “control” and clicking) and choose “Get Info”. Click the
“Info” Tab.

Here you will see a window where the metadata can be set. You MUST, to the best
of your ability, fill out the following fields:

Name

Artist

Year

Track Number
Album
Comments
Genre

Under “Name,” write the name of the track. If it is unsegmented audio, you can
generally use the terms “Complete Reading” or “Complete Recording.” If there are
many authors reading at a single reading, you can also name the track as the
author’s name.

Under artist, write the name of the author reading.

Under year, write the year the recording took place.

There are two track number boxes, the one on the left is the current track’s
number, and the second is the total number of tracks.

Albums should give as much information as possible. The order should be Series,
Location, and Date. This can be expanded to include the name of a particular book



or talk title at the beginning if applicable. Please spell out the full date (ie, June 1,
2011, not 6/1/10).

Under comments, the copyright and distribution information is written. This is
written as:

© current year author’s name/estate. Distributed by PennSound
(http://writing.upenn.edu/pennsound/).

Finally, the genre should always be listed as “PennSound.”

Please reference the image below as an example of what the completed metadata
should look like.

® iTunes File Edit View Controls Store Advanced Window Help
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1 TV Shows
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STORE Name
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CENIUS Album Disc Number I n
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If you have segmented audio, or multiple tracks for which some of the metadata
will be the same, then you will want to set the metadata in batch form. Begin by
selecting all of the tracks for which you wish to set the metadata. This can easily be
accomplished by clicking the first track in the list, and then, while holding shift,
click the last track. Right-click any part of the selection (on MACs this is
accomplished by holding “control” and clicking) and choose “Get Info”. Click the


http://writing.upenn.edu/pennsound/

“Info” Tab.

Here you will see the window where the metadata can be set as a batch. Fill out
any information that will be the same for every track (usually artist, year, the
second track number box, album, comments, and genre).

TIP: If you have multiple tracks from the same album, begin with the first track, and
individually set the track numbers before editing the rest of the metadata. This will
ensure that the tracks stay in the correct order as you change author and title names
later on.

2.7: Naming Files

Now that the metadata is set, the last thing you need to do before the audio is
ready to be uploaded is name the file under PennSound protocols. Naming
conventions work as follows:

Lastname-Firstname_TrackNumber_Title_Series_Location_Date

Notice that there are no spaces in the title. Any space should be replaced with a “-“,
while underscores are used to separate the fields. A correctly named track will
look like the following:

DiPalma-Ray_09_Poem-De-La-Gorra_Instrumentaria_Studio-111_UPenn_4-3-
12.mp3

Once again, tracks 1-9 are labeled as “01” to “09”. Year is given in the month-day-
year format, with no “0” in front.

Now that your files are named, they’re ready for the Media Server! See Chapter 4
for a detailed explanation of the Media Server and how to upload material.

TIP: When naming files, using the copy + paste functions to your advantage! It’s
fastest to make the filenames all at once in a text document, then copy them to the
track itself. Even when making the filenames in the text document, copy + paste can
be useful, since most segmented recordings will differ only in track number and title.



Chapter 3: Video on PennSound

3.1: Video Standards

SAS Computing has graciously created a video tutorial on how to prepare video for
the Media Server. You can view the video at the following link:
http://media.sas.upenn.edu/watch /93215

The information that is important to remember as far as settings go follows:

In order to stream, videos must be Quicktime, MPEG 4, or Flash videos. The
file name extensions for these formats are:

« .mov
- .mp4
- .m4a
o flv

For Quicktime and MPEG 4 videos, the following codecs must be used:
For video, use H.264 compression. For sound, use AAC compression.

While not necessary in order to stream properly, we prefer that you use:

4:3 Standard Aspect Ratio
Frame Rate: 30 fps
Size Dimensions: 640 x 480

3.2: Downloading a video from external sites

While oftentimes the videos you receive will be downloaded from the media
server (see Chapter 4 for a detailed explanation of the media server), occasionally
you will have to download a video that is streaming on YouTube. The easiest way
to download these videos is to use KeepVid: http://www.keepvid.com/

On this page, simply paste the link of the video you wish to download, and hit the
“Download” button. The site will generate a list of links to download the video in a
variety of formats. For PennSound, right click the “Download MP4 (max 480 p)
link, and select “Save Link As.” This file will already be correctly formatted for our
media server, and will only need to be named according to PennSound
conventions (Chapter 2.7) before being uploaded.


http://www.keepvid.com/
http://media.sas.upenn.edu/watch/93215

3.3: Using Handbrake

Handbrake is a program that is used to rip video files from DVDs, as well as

convert video settings.

In order to rip video from a DVD, begin by inserting the disc into your computer

and opening the Handbrake program. You will immediately be prompted to

choose the source of the video. Choose the disc from the menu.

If you are converting an existing video file on your computer, then choose that file,

rather than a disc.

If you are not prompted upon startup, you can also access this by clicking the
“Source” button on the top-left section of the window. Handbrake will take a
moment to analyze the source, and then display a window that looks similar to the

following:
# HandBrake File Edit Presets Window Help
. Hel& HandBrake =
@) ) [P @) 2 . =
ﬁ W N & L"B g - - |} ¥ Devices
Source Start Pause Add to Queue Show Queue Picture Settings Preview Window Activity Window Toggle Presets Universal
iPod
Source: AGAINST_THE_SLOPE iPhone & iPod Touch
— — = iPhone 4
Title: [ 1 - 01h16moss 5]  Angle: (1 i8] [ Chapters 18] [ 12 #) through [ 8 3] Duration: 01:16:05 iPad
Destination AppleTv
AppleTV 2
File: | jUsers/jeff/Desktop/AGAINST_THE_SLOPE.mdv ( Browse . ) Android Mid
Android High
Output Settings: iPhone & iPod Touch ¥ Regular
Format: | MP4 file = [ Large file size ] Web optimized [ iPod 5G support N.ormal .
High Profile
P Legacy
[ Video | Audio Subtitles Advanced Chapters |
Video Codec: H.264 (xzstﬁ v Framerate (FPS): | Same as source v ] (® variable Framerate
O Ceonstant Framerate
Video Quality:
®) Constant Quality RF: 20
C! Average Bitrate (kbps): 960 2-pass encoding
Picture Size: Source: 720x480, Qutput: 480x272, Modulus: 16
Picture Cropping: Auto 54/56/0/0
Video Filters:
-

No encode pending

Confirm that the recording you wish to rip is the one selected. Click the drop-down
box next to “Title” in the top-left section of the screen. If there are multiple listings,
you generally want the longest one (DVDs with menus and multiple files will list

several titles, the longest is usually the “feature” of the DVD).

Next, on the far right, choose the “iPhone and iPod Touch” present. These presets
are perfect for streaming on the media server. You'll notice the information in the

main box will likely change to match the iPhone presets.



Next, confirm that the “Destination” is the correct location on your computer. If it
is not set for the Desktop, click the “Browse” button and select the Desktop as the
destination. Finally, click in the Destination box, and manually change the “m4v”
to “mp4”.

TIP: Always set the preset to “IPhone” and confirm the destination before changing
the video extension, as it will reset to “m4v” if you change either setting afterward.

Click the start button and wait for the file to convert. After Handbrake finishes
running, find the video on your desktop, and play it to confirm that the process
worked correctly.

3.4: Using Final Cut Express

Final Cut Express is a video editing program that is available on the PennSound02
machine in the PennSound office. It is not an immediately intuitive program,
although it is a powerful editing tool. It is used to digitize VHS tapes, edit existing
video, and add watermarks.

Because of the steep learning curve of Final Cut, and the multitude of things that
can go wrong with even the tiniest error, there will not be instructions in this
manual. However, should the need to edit video arise, there are many resources
available for you to learn Final Cut.

As a PennCard holder, you are entitled to use the Vitale Digital Media Lab, in the
Weigle Information Commons on the first floor of Van Pelt Library. The staff there
are willing to answer any questions you might have about Final Cut, and guide you
through the process in a hands on manner. They also offer group training courses
in Final Cut, as well as other programs. More information on the Vitale Digital
Media Lab, including course listings, can be found on their website:
http://wiclibrary.upenn.edu/wicfacilities /lab.html

Another more time-consuming option for current students is to take the “Video 1”
course in the Cinema Studies department. Offered once a semester, the course will
teach you the basics of Final Cut and video editing, as well as film-making
techniques. While this training would be beyond what is required for PennSound,
it is an option to consider if you have time and need an elective.

Finally, there are a number of online text and video tutorials on how to use Final
Cut. Its status as the most popular professional video editing software in the world
means there is no dearth of information should you wish to learn the program.


http://wic.library.upenn.edu/wicfacilities/lab.html

Chapter 4: Using the Media Server

4.1: Introducing the Media Server

The Media Server is one of two servers used by PennSound. As the name implies, it
is where all of the media (audio files, video files, and images) used for the site is
located. It can be found online at http://media.sas.upenn.edu, and is accessible
with your Penn Key and password.

The first page when you visit the Media Server will look like this:

® Chrome File FEdit View History Bookmarks Window Help

8no6 P Media Manager

[ | ®scrcn | [P umproadiccoyorric

My directories "Current directory’

Home /

Report a technical problem

Log out Name Kind Size  Open file
media_root Directory - -
media_rootprotected Directory - -
web_root Dirsctory
web_rootprotected Directory

School of Arts & Sciences | College of Aris & Sciences | Graduate Division | Liberal & Professional Studies | University of Pennsylvania

A

Each of these four folders (media_root, media_root/protected, web_root, and
web_root/protected) has a folder labeled PennSound within it. The media_root
folders are used exclusively for video files, while the web_root folders are used for
audio files and images.

media_root houses all video content for School of Arts and Sciences. Upon clicking
this link, navigate to and click the “pennsound” folder. You will see the following
screen:


http://media.sas.upenn.edu/
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Only two of the folders here will be used on a constant basis: “authors” and
“groups”. Clicking “authors” will bring you to a list of folders labeled by authors’
last names. Inside of each of these folders is a list of video files for that particular
poet. The left side of the screen lists the file name, while the right side is a link
directly to the streaming video. The “groups” folder is constructed in the same
manner, except rather than list particular authors, folders are named after specific
events—usually reading series or conferences.

media_root/protected has only the “pennsound” directory. This directory is used
exclusively for videos that are not permissioned for the website, but that we have
either for future posting or preservation. This directory cannot be seen by the
seen by the public, and videos from this directory should not be linked on any
website.

web_root contains the majority of PennSound’s media on the server. Enter this
folder and navigate to the “pennsound” folder. Enter this directory will give you
the following listing:
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The “authors” and “groups” folders function exactly as they do in the media_root:
authors are categorized by last names, and groups list series/events/collective
readings. Because there are many more mp3s than video files (this is PennSOUND
after all), within these lists of authors and groups are folders with dates or specific
readings listed. These house segmented files for a particular reading, in order to
make directories easier to navigate.

The “KWH-Inbox” folder is where all recordings made at the Kelly Writers House
will be uploaded. This should be checked periodically during the academic year for
recordings. They will be uploaded in .mov, and should have their audio ripped.
Once the .mov had been uploaded to the media_root, and the extracted MP3 has
been uploaded to the web_root, the file should be deleted from the Inbox.

The “misc” folder should also be noted. Its most important role is that it houses the
“Images” folder. While images are now uploaded directly to the author or group
directory to which it belongs, there is a “Previews” directory which is often used.
The images in this directory are the preview images that are displayed when a
video is embedded on PennSound, and will be discussed in Chapter 5.5: Editing a
Page-Existing Pages.

Also in the main pennsound directory is the “temp” folder. While used sparingly, it
is used mostly as an intermediary directory. Someone may, for example, upload a
file to this directory for you to download and edit, or you may use to upload a file
from one computer, and download to another.

The web_root/protected folder functions exactly like the media_root/protected
folder. These recordings are not permissioned, and not to be made available to the



public. There are some wonderful recordings in this directory, however, so feel
free to browse it yourself (it's a great perk of the job!)

4.2 Uploading Content

Once content has been prepared for the Media Server, it's time to upload it!
Navigate to the appropriate folder. If a folder for the author or group doesn’t exist,
click the “Create Subdirectory” button, and name the folder appropriately. Once
you are in the correct directory, hit the “Upload Files” button. A window will pop
up with the choices “Select files” or “Cancel”.

Select the files from your computer, and a list will appear in the window. Click the
“Upload” button and they will be uploaded to the site.

[t is important to remember that the upload will occur more slowly, or may not
begin if you navigate to a new tab in your web browser. Please wait for the files to
begin uploading before moving on. Also bear in mind that there is a 1 gigabyte
limit to any file. Files should never be that large, and will either need to be split, or
re-exported through Audacity/Handbrake to decrease their size

TIP: If you're uploading many files at once, do not select more than 20 at a time. The
Media Server will over display in the web browser, and you will not be able to click
the “Upload” button. If you have more than 20 files to upload, upload in smaller
batches, rather than all at once.

Finally the metadata should have been already set on your audio files via iTunes.
Pictures do not need to have their metadata tagged, but videos do. Follow the
directions below (Chapter 4.3) to edit metadata on the server, and tag the Videos
as: Author Name -- Title, Location, Date

4.3 Editing Content on the Media Server

Once files are on the Media Server, they can still be renamed, or have their
metadata changed. When looking at the file in its directory, you will see the listing
of each item as:

Filename Size of File Link to File

If there is metadata already set, it will appear above the filename. Clicking the
filename will open the following window with information about the recording:
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Kind: audio/mpeg
Size: 2120 kB
Duration: 00:02:15
Uploaded: 2011-02-04 10:21:29 by annazal
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Genre: PennSound

r~Audio information
Bitrate: 128 kbps
Sample rate: 44.1 kHz
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This window lists, in order: Links to download the file, Information about the file
on the server (including length of the recording, the user to originally upload the
item, and the last person to modify the item), Metadata for the Item, and Codec
information.

At the top of the window, you'll see three links that allow you to edit the content
on the Media Server: Rename, Edit Metadata, and Delete. “Rename” allows you to
change the filename (so if you caught a typo from earlier, don’t worry about it
right away, wait till it's uploaded and change it there!). “Edit Metadata” allows you
to set and correct the metadata, and “Delete” allows you to delete the item from
the server.

Keep in mind as well—the ability to rename and delete directories on the media
server is available as well, and can be seen next to the “Upload” button within a
directory. When editing directories, however, BE CAREFUL. Mistakes cannot only
cause all of PennSound to lose functionality, but can cause the entire website to be
deleted. Which has happened before. Twice. So watch out!



Chapter 5: Using the Writing Server

5.1: Introducing the Writing Server

The Writing Server is the second sever utilized by PennSound, alongside the Media
Server. While the Media Server is used to host the actual recordings, the Writing
Server is the storage space for all of our coded pages. This means that it is seen in
the browser by going to http://writing.upenn.edu, and URLs such as
http://writing.upenn.edu/pennsound/x/Armantrout.php reflect the directory
structure within the Writing Server.

As you probably noticed, going to these pages brings up the actual page display,
unlike the Media Server URLs, which access the back-end of the site. In order to
access and edit these Writing Server pages, you must use Text Wrangler (MAC) or
jEdit (PC). Follow the instructions in Chapter 1 in order to configure these
programs properly.

Once your program of choice is configured, open it and click File>Connect to
FTP/SFTP Server. Use your bookmark to open the main PennSound section of the
Writing Server, which should look like this:


http://writing.upenn.edu/pennsound/x/Armantrout.php
http://writing.upenn.edu/
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Scrolling down will reveal more directories (these are visualized with the folder
icon, but are properly called and henceforth referred to as directories), the
complete list of which is:

Alignment
Chrisnewplayertest
Classuse

Css

Daily

Error

Images

Misc

News

Php

Playtagger_mod

Singles

Sopa-strike_files

Source

To_be_examined

X

xmlbackups
xmlbackups_9-08-to-8-09
xmlbackups_9-09-to-8-10
xmlbackups_9-10-to-8-11

Of these directories, only two are of the utmost importance. “source” houses key
files for PennSound: authors.html and newatpennsound.html.

The other crucial directory is the x directory, where nearly all of the content of
PennSound is housed. Here you will find every author page, as well as the
protected/Permissions directory, where author permission notices are uploaded.
When navigating to an author page to edit, you will open the x directory, and find
that author’s page, organized by last name.

5.2: How to Create a Page

While often on PennSound you will be editing the content of pages that already
exist, we are constantly adding new authors and series to our site. Doing this
requires the creation of a new PHP page.

In order to create and delete PHP and HTML pages, you must use Secure CRT (PC)
or Terminal, which is native to 0SX, and should already be on your MAC. Users of
Secure CRT should follow the directions in Chapter One to configure the program
properly, and connect to the Writing Server. MAC users need simply click the
search tool (the magnifying glass icon) in the top right of their screen, and type the



word “Terminal” into the search bar. The program should be listed. Open it to find
a UNIX command screen. To connect to the server, type the following command:

ssh user@writing.upenn.edu

Replace the word “user” with your Penn Key. Press the “Enter” key and type your
password, bearing in mind that the characters WILL NOT appear in the screen.
The resulting screen should look like this:

# Terminal Shell Edit View Window Help
SN o boruszak@writing:~ — ssh — 80x24

Last login: Fri May 25 13:3E:18 on console =]
pennsound@2:~ jeffs ssh boruszak@writing.upenn.edu

boruszak@writing.upenn.edu's password:

Last login: Tue May B 13:25:41 2812 from pennsound@l.writing.upenn.edu

[B2:86 PM boruszak@writing ~]%

Type the word “pennsound” (minus quotes but keeping the lowercase), and press
enter. This is a shortcut that will take you to the PennSound directory of the
writing server.

Next, type the term “cd x” and press enter. “cd” is the command for “change
directory”, and this will bring you to the x directory.

TIP: Although you won'’t need this command, you can view the content of a directory
by typing “Is -1”. This “list” command will display the contents of the directory,
including permissions, file size, the last user to edit the file, and the last edit date of
the file. If you're getting errors when you try to use commands, chances are you're
not in the directory you think you are, and the list command will let you know if
that’s the case. Often this comes from forgetting to type “pennsound” to go to the
pennsound directory.



The easiest way to create a new page is simply to copy an existing page and then
edit it. This will ensure that the CSS (explained in 5.4: Editing a Page) works for
the page. Choose any relatively new existing page and type the following
command:

cp Old-Page.php New-Page.php

The command “cp” stands for “Copy Paste,” and you should always list the old
page first, and the page you are creating second.

Now that the page exists, you must set the permissions for it. Type the following
command:

chmod 664 New-Page.php

This sets the read /write permissions for the page. When creating page names,
remember these things:

1. ALWAYS use capital letters at the beginning of a name/word

2. NEVER use spaces. Like Filenames, always use dashes.

3. Author pages are usually Lastname.php. If that last name is already in use,
then use Lastname-Firstname.php.

4. When in doubt about how to format the name for a page, ALWAYS look at
existing pages on PennSound, and follow their formats.

Type the word “exit” into Terminal/Secure CRT to close your connection with the
server. Now if you open Text Wrangler/jEdit and navigate to the x directory, you
should be able to find your newly created page. Now you're ready to edit this page.
But first you need to know the basics of HTML.

5.3: How to use HTML

HTML, or Hyper Text Markup Language, is the basic computer programming
language used to write webpages. This section will serve as a brief tutorial for the
basics of HTML.

If you are new to HTML, don’t fret. There is a slight learning curve to the language,
once you get used to the format, it is a fairly basic process. To begin, all HTML
language consists of tags. These tags are written in between brackets: <>

Tags modify how the text is displayed. For example, without using HTML, all text
will display in the same size and font, much like the very text you are reading now.

But if we use a tag to bold something (which is the <b> tag), then:

The bold text will be displayed.



HTML, unfortunately, is a very precise and nitpicky language. It needs you to tell it
everything that you want it to do, and tell it in exact terms. Failing to do so will
cause the text to display incorrectly. There are two things you need to remember
about HTML:

1.

2.

Every tag must be opened and closed (with very specific exceptions on
closing which will be noted below!). Opening means placing a tag before
the text you want to modify, and closing means placing the tag after the text
you want to modify, with a slash inside of it. Eg, opening bold text means
placing a <b> before that text, and </b> after it.
Therefore, typing: <b>This is bold text</b>

Will produce
This is bold text
When using multiple tags on one string of text, tags must be closed in the
reverse order that they are opened. If you want to underline text (<u>) as
well as bold it, you would type:

<b><u>This text is bold and underlined</u></b>

in order to produce:

This text is bold and underlined

This property is commutative—that is, the order of the initial tags does not
matter. If you were to use the underline tag before the bold tag (<u><b>) it
would produce the same result, as long as you close in the reverse order
(</b></u>). Moreover, this process works for an infinite number of tags.
[talicizing the text as well (<i>) could be typed as:

<i><b><u>This text is bold, underlined, and italicized</u></b></i>
In order to produce:

This text is bold, underlined, and italicized

The following is a list of HTML tags. If you ever need to know an HTML that is not
listed below, Google should produce a quick result.



LIST OF HTML CODES

Headings

Heading produced standardized larger text, and should be used on author
names, and information on recordings. They come in three sizes used for
PennSound: Heading 1, Heading 2, and Heading 3. The codes for these, and the
display for their tags are:

<h1>-- Heading 1
<h2> -- Heading 2
<h3> -- Heading 3

Text Formatting
The follow are the codes for standard text formatting.

<b> -- Bold
<u> -- Underline
<i> -- Italic

<p> -- Paragraph -This automatically formats text as a paragraph, inserting
a line break before and after the block of text. This DOES NOT create an
indent for the paragraph.

Lists

The following tags are used to create lists, and how recordings are posted
on most pages. There are two kinds of lists, Ordered Lists and Unordered Lists.
Ordered Lists create an indent and list each item with a number, while Unordered
Lists create indent the list and place no character in front of each item. These are
coded and displayed as:

<ol>

<li>List [tem 1</li>
<li>List [tem 2</li>
<li>List [tem 3</li>
</ol>

Producing,
1. ListItem 1
2. ListItem 2
3. ListItem 3

And,



<ul>

<li>List Item 1</li>
<li>List [tem 2</li>
<li>List Item 3</li>
</ul>

Producing,

List Item 1
List Item 2
List Item 3

The <li> tag stands for “list item” and it is important to place everything to be
displayed on a line between the <li> and </li> tags. Lists can be modified with
code inside the opening tag, although you would rarely have to use this. The most
important (and likely only one you would use) is the Bulleted attribute. You would
code this by writing class="bullet” in the opening tag. So,

<ul class="bullet”>
<li>List Item 1</li>
<li>List Item 2</li>
<li>List Item 3</li>
</ul>

Produces

e Listltem1
e ListItem 2
e ListItem 3

Anchor Tags

Anchor tags are a class of tags represented as <a>. They have two uses. One
is used to mark certain parts of a page for hyperlinking. This is done with the
“name attribute”. If on a part of the page you were to insert the code:

<a name="Poem”>

No text would be displayed. But an invisible bookmark would be placed at that
point on the page, so that adding a pound sign (#) and the name of the tag would
bring you directly to that point on the page. On PennSound we use these to mark
new recordings we post and then link to, using the date of the recording as the
name. So the URL http://writing.upenn.edu/pennsound/x/DiPalma.php#4-2-12
brings you to the recording that took place on April 2, 2012, instead of the top of
the page. SETTING AN ANCHOR NAME DOES NOT REQUIRE YOU TO CLOSE THE
TAG. In this case there is no </a>.



http://writing.upenn.edu/pennsound/x/DiPalma.php#4-2-12

The other use of an Anchor tag is in creating a hyperlink. This is done with “href”
attribute. The code looks like:

<a href="http://writing.upenn.edu/pennsound/x/DiPalma.php#4-2-12">Link to
Ray DiPalma</a>

and displays:

Link to Ray DiPalma

There are a few important things to remember about creating Hyperlinks:

1. The URL you are linking to MUST be placed between quotes. If you forget
one or both quotation marks, the link will not work.

2. Unlike the anchor name, the hyperlink MUST be closed with the </a> tag.

3. The text that you wish to display as a hyperlink must be placed between the
two tags.

Images

Images are used often on the site, and it is important that you know not just
how to post images, but change the attributed of the image with HTML. Images are
posted using the tag:

<img src="Image-Url">

Remember that this is one of the few tags THAT DOES NOT HAVE TO BE
CLOSED. Images will be stored on the Media Server, so just insert the image’s URL
between quotation marks. The attributes that you should know of are: align,
height, and width. Align will place the image on a part of the page and have text
move around it (see the Heatstrings Page for an example of this). It is coded as:

<img align="left” src="Image-URL">
or
<img align="right” src="Image-URL">

The direction sets the side of the page to paste the image. Height and Width,
meanwhile, set fixed dimensions for an image to display, rather than the full size of
the image. These numbers are placed in pixels. It is mostly your judgement what
size to display pictures, but try to keep them with a height of less than 500 pixels,
and a width of less than 700. This would be coded as:

<img height="500" width="700" src="Image-Url">

To check an images dimensions, open an image and in your image editor and find
the “Adjust Size” tab under “Tools.” The drop-down box on the right should be


http://writing.upenn.edu/pennsound/x/Heatstrings.php
http://writing.upenn.edu/pennsound/x/DiPalma.php#4-2-12

changed to display in pixels. Make sure the “scale proportionately” box is checked,
and play with the numbers until you find a size you like, and enter these numbers
into the code.

NOTE: Scans of CD covers are occasionally posted, they should be posted with a
height of 377, and a width of 700. See Musicacha as an example.

Miscellaneous Tags
The following are tags that are used on PennSound, and which you will use
often, but which do not fit into the above major categories.

<br> -- Break

The <br> tag will create a line break. Two <br> tags in a row will create two
breaks. This is equivalent to pressing the “enter” key in a word processing
program. Pressing the “enter” key when editing HTML will not create a line break,
so remember to use this tag!

<font> -- Change the font

This tag is really only used in one instance. When creating a caption under an
image, the font size needs to be lowered, so place the caption after the tag <font
size="-1"> and then close the tag with </font>.

There are also a variety of special characters that must be coded in order to
display. These include the copyright symbol (©), accented vowels (é), and foreign
characters (p). Any character not found on a US Keyboard MUST be encoded as a
special character. A list with the codes for many characters can be found here:
http://www.utexas.edu/learn/html/spchar.html. If the character you need isn’t
listed, try using Google (HTML Code + name of the character usually works). If you
don’t know the name of a character, Google is usually good at helping you if you
try describing it. For example, the search “special characters looks like a p” results
in a page that lists the third character above, the thorn - p.

5.4 Editing a Page — New Page

So now that you know HTML, you're ready to begin editing pages. The first
thing we’ll cover is what to do with a new PHP page that you've created (Chapter
5.2). Let’s start by breaking down what a page looks like. The picture below is a
simple PennSound Page:


http://www.utexas.edu/learn/html/spchar.html
http://writing.upenn.edu/pennsound/x/Silva.php#Musicacha

|2 Silva.php =

| Last Saved: 11/2/10 10:19:49 AM
2 Lf’ T . File Path v : sftp://boruszak: upenn.edu d i va.php

< [ » [o[} silva.php %/ (no symbol selected) + . *o
¥ | <?php
require_once(" /www/data/writing/pennsound/php/pennsound.php');

1
2
3
4 Stype = 'main’;
5 $title = 'PennSound: Wilmar Silva';
5 Sflashplayer = 'yes';

7

8

// HTML for page goes below this "<<<PAGECONTENT" line
9 $page_content = <<<PAGECONTENT

1 <hl>Wilmar Silva</hls>

13 <a name="Musicacha">
14 <h2><i>Musicacha</i>, poems from the book <i>Cachaprego</i>, music by Gilberto Mauro, 2005-2009</h2>

15 <img width-"700" height-"377" src-"http://media.sas.upenn.edu/pennsound/authars/Silva/Musicacha/Musicacha-1. jpg">
16 <img width="700" height="377" src="http://media.sas.upenn.edu/pennspund/authors/Silva/Musicacha/Musicacha-2. jpg">
17 <ol>

18 <li>Musicacha I (1:45): <a href="http://media.sas.upenn.edu/pennsound/authors/Silva/Musicacha/$ilva-Wilmar_01_Musicacha-I_Musicacha_2009.mp3">MP3</a></1i>
19 <li>Musicacha XX (1:31): <a href="http://media.sas.upenn.edu/pennsound/authors/5ilva/Musicacha/Silva-Wilmar_82_Musicacha-XX_Musicacha_2@89.mp3">MP3</a></1i>
20 <li>Musicacha XXVI (2:20): <a href="http://media.sas.upenn.edu/pennseund/authors/Silva/Musicacha/Silva-Wilmar_03_Musicacha-XXVI_Musicacha_2009.mp3">MP3</a></1i>

21 <li>Musicacha X (2:32): <a href="http://media.sas.upenn.edu/pennsound/authors/Silva/Musicacha/Silva-Wilmar_@4_Musicacha-X_Musicacha_20@9.mp3">MP3</a></1i>

22 <li>Musicacha XVI (2:38): <a href="http://media.sas.upenn.edu/pennsound/authors/Silva/Musicacha/Silva-Wilmar_85_Musicacha-XVI_Musicacha_20@3.mp3">MP3</a></11>

23 <li>Musicacha XXI (2:05): <a href="http://media.sas.upenn.edu/pennsound/authors/Silva/Musicacha/Silva-Wilmar_06_Musicacha-XXI_Musicacha_2009.mp3">MP3</a></1i>

24 <li>Musicacha XXVII (1:29): <a href="http://media.sas.upenn.edu/pennsound/authors/Silva/Musicacha/Silva-Wilmar_87_Musicacha-XXVII_Musicacha_2009.mp3">MP3</a></1i>
25 <li>Musicacha VII (3:02): <a href="http://media.sas.upenn.edu/pennsound/authors/Silva/Musicacha/Silva-Wilmar_08_Musicacha-VII_Musicacha_2009.mp3">MP3</a></11>

26 <li>Musicacha IX (1:49): <a href="http://media.sas.upenn.edu/pennsound/authors/5ilva/Musicacha/Silva-Wilmar_83_Musicacha-IX_Musicacha_2069.mp3">MP3</a></1i>

27 <li>Musicacha XXV (3:11): <a href="http://media.sas.upenn. edu/pennsound/authors/Silva/Musicacha/Silva-Wilmar_1@_Musicacha-XXV_Musicacha_2009.mp3">MP3</a></11>

8 </ol>

20

30| | <p>These sound recordings are being made available for noncommercial and educational use only.

31| | All rights to this recorded material belong to the author. &copy; 2010 Wilmar Silva.

32| | Used with the permission of Wilmar Silva. Distributed by <a href="../index.html">PennSound.</a></p> J

34| | PAGECONTENT;
35| | // HTML for page goes above the "PAGECONTENT;" line

16 68 HTML % | Unicode (UTF-8) % |Windows (CRLF) +| || 2,614 /32839 4

This is a complete page with only one main listing on it, and for the purposes of
this tutorial, is the perfect example. Each PennSound Page has three important
sections, and we’ll examine each individually. The first is the top portion of the

page:

o /9 -'I-"”' Last Saved: 11/2/10 10:19:49 AM
Fi. -~ File Path v : sftp://boruszak:@writing.upenn.edu/ /www/data/writing/pennsound x/5ilva.

"

4  » o7 Siva.php = (nosymbol selected) =
1|¥| <?php

2 require_once( ' /www/data/writing/pennsound/php/pennsound.php');
3

4 $type = "main';

5 $title = 'PennSound: Wilmar Silva';

6 $flashplayer = 'yes';

7

8 // HTML for page goes below this "<<<PAGECONTENT" line

9 $page_content = <<<PAGECONTENT

10

This section contain the CSS (Stylesheet) for the page. The CSS is code that is on
every page that makes the background green, sets the text size, and displays the
links that appear on every page. Most of this section you won'’t edit. The one
exception is the entry that says “$title = “. This entry sets the name of the page on
the top of your Browser. When creating a new page, you should change this first to
the name of the author for whom you are creating the page.

The next section of a page is the main body:



<hl=Wilmar Silva</hl>

<a name="Musicacha">

<hZ><i>Musicacha</i>, poems from the book <i>Cachaprego</i>, music by Gilberto Mauro, 2005-2009</hZ>

<img width="70@" height="377" src="http://media.sas.upenn.edu/pennsound/authors/Silva/Musicacha/Musicacha-1.jpg">

<img width="700" height="377" src="http://media.sas.upenn.edu/pennspund/authors/SilvaMusicacha/Musicacha-2.jpg">

<ol>

<lisMusicacha I (1:45): <a href="http://media.sas.upenn.edu/pennsound/authors/Silva/Musicacha/Silva-Wilmar_@1_Musicacha-I_Musicacha_2009 .mp3">MP3</a></1i>
<lizMusicacha XX (1:31): <a href="http://media.sas.upenn.edu/pennsound/authors/5ilva/Musicacha/5ilva-Wilmar_82_Musicacha-XX_Musicacha_2@@9.mp3">MP3</a></11>
<li>Musicacha XXVI (2:2@): <a hr tp://media.sas.upenn. edu/pennsound/authors/Silva/Musicacha/Silva-Wilmar_83_Musicacha-XXVI_Musicacha_2009.mp3">MP3</a></1i>
<li>Musicacha X (2:32): <a href="http://media.sas.upenn.edu/pennsound/authors/5ilva/Musicacha/Silva-Wilmar_04_Musicacha-X_Musicacha_2009.mp3">MP3</a></11i>
<lisMusicacha XVI (2:3@): <a href="http://media.sos.upenn.edu/pennsound/authors/Silva/Musicacha/Silva-Wilmar_@5_Musicacha-XVI_Musicacha_20@9.mp3">MP3</a></1i>
<li>Musicacha XXI (2:85): <a href="http://media.sas.upenn.edu/pennsound/authors/Silva/Musicacha/Silva-Wilmar_86_Musicacha-XXI_Musicacha_20@9.mp3">MP3</a></11>
<li>Musicacha XXVII (1:29): <a href="http://media.sas.upenn.edu/pennsound/authors/Silva/Musicacha/Silva-Wilmar_87_Musicacha-XXVII_Musicacha_2009.mp3">MP3</a></11i>

<lisMusicacha VII (3:02): <a href="http://media.sas.upenn.edu/pennsound/authors/Silva/Musicacha/Silva-Wilmar_88_Musicacha-VII_Musicacha_2009.mp3">MP3</a></1i>
<lizMusicacha IX (1:49): <a href="http://media.sas.upenn.edu/pennsound/authors/5ilva/Musicacha/5ilva-Wilmar_89_Musicacha-IX_Musicacha_20@9.mp3">MP3</a></11>
<lizMusicacha XXV (3:11): <a href="http://media.sas.upenn.edu/pennsound/authors/SilvaMusicacha/Silva-Wilmar_18_Musicacha-XXV_Musicacha_2089 .mp3">MP3</a></11>
</ol>

This is where the Author’s main name listing, photos, and all recordings are
placed. When creating a new page, just delete everything in this section, and create
a new heading with the Author’s name (<h1>Author</h1>) in its place.

Finally is the end section of the page:

<p>These sound recordings are being made available for noncommercial and educational use only.
All rights to this recorded material belong to the author. &copy; 2018 Wilmar S5ilva.
Used with the permission of Wilmar Silwva. Distributed by <a href="../index.html">PennSound.</a></p>

PAGECONTENT;
// HTML for page goes above the "PAGECONTENT;" line

This notice should be edited in three places. First, after the copyright tag, change
the year to the current year in which you are creating the page. Next, change the
name to the author’s name (or, if the author is dead, to “The Estate of Author”).
Finally change the name in the same manner on the next line. The
“PAGECONTENT” and everything below is also part of the CSS, and should not be
edited.

5.5: Editing a Page - Existing Pages

Once you've prepared the page according to Chapter 5.4 (or if the page
already exists, you're here and ready to edit!), you can begin linking recordings to
the page. The first thing you need to know is that on author pages, recordings are
listed REVERSE-CHRONOLOGICALLY, meaning that the newest recordings are
placed at the top, and oldest at the bottom. Meanwhile, on a series page,
recordings are CHRONOLOGICAL—oldest first, newest last. The two exceptions to
these rules:

1. Some pages were created before this was standardized—just follow the

format already on the page.

2. Some recordings, such as Studio 111 sessions, or Close Listening
programs, are placed at the top of the page, with an <hr> tag
afterwards. This draws a line across the page. In this case leave those
recordings at the top of the page, and treat the page normally AFTER
the <hr> tag.



Editing a page with all items (complete recording, segmented recordings, and
video) will produce a listing that looks like the following:

Search

Reading at the Kelly Writers House, University of Pennsylvania, April 2, 2012

. introduction by Charles Bernstein (4:43): @ MP3
. August 24, 2005 (3:33): @ MP3

. Sequel 11 (2:16): @ MP3

. Sequel 17 (0:42): @ MP3

Further Apocrypha (2:37): @ MP3

. The House (0:58): & MP3

. The Darkness Beyond a Glare (1:36): @ MP3
. Asking (0:47): @ MP3

. From Obelisk to Water's Edge (1:12): @ MP3
10. A Chinese Pillow (1:18): @ MP3

11. On the Uselessness of Poetry for Assuring the Stability of Modern Buildings (1:28): @ MP3
12. 99 Years in Fishtown (1:14): @ MP3

13. Homage to lago (1:23): @ MP3

14. Shakespeare With a Gun (5:29): @ MP3

15. Untitled (2:11): @ MP3

16. Penstroke to Fig Tree (1:47): @ MP3

17. | Hid but Here | Am (1:16): @ MP3

18. The Cult of Conversation (0:53): @ MP3

19. August 5, 2005 (1:00): @ MP3

| 20. Homage to Diseeka (2:03): & MP3

; 21. from An August Day Book (4:13): & MP3

22. August 22, 2005 (3:32): @ MP3

23. The Falsetto of Reason (2:00): @ MP3

24. Q& A (1427): G MP3

CONOUAWN

1 complete reading (1:04:02): @ MP3

p H | o000 oo:00 | [l | <@ il

Let’s examine the pieces required to post a recording. First is the Heading.

The Heading, placed between <h2> tags, contains the identifying information
about the recording. Generally it is the same as the “Album” section of the
metadata, and contains information about the recording in the same order as the
filename. List what the recording is (reading, lecture, talk, presentation, etc.), the
series, location, and date. Crosslink to other PennSound pages (use the <a href>
tag) for appropriate series or author names. If the recording was at the Kelly
Writers House, then on the date link to that entry on the Kelly Writers House
Calendar.

In the case of the heading in the picture above, the HTML reads as:

<h2>Reading at the Kelly Writers House, University of Pennsylvania, <a
href="http://writing.upenn.edu/wh/calendar/0412.php#2">April 2,
2012</a></h2>


http://writing.upenn.edu/wh/calendar/
http://writing.upenn.edu/wh/calendar/

Next is the list of segmented recordings. These are generally placed in the ordered
list (<o0l>). Recordings ALWAYS follow the same order in list:

Track Title (Time): MP3
In the case of the recordings above, a list item entry reads like:

<li>August 24, 2005 (3:33): <a
href="http://media.sas.upenn.edu/pennsound/authors/DiPalma/4-2-
12 /DiPalma-Ray_02_August-24-2005_KWH-UPenn_4-2-12.mp3">MP3</a></li>

TIP: Always remember to close the <a> tag after the “MP3” and before closing the
<li> tag.

TIP: Remember making the list of recordings to name the files before uploading? You
can use that document to make posting recordings even easier. Copy and paste the
list of filenames into your HTML editor. Using the crtl+c and crtl+v commands, add

.mp3”">MP3</a></li>
to the end of each filename. Then, in front of each file name, add

<li>introduction (): <a
href="http://media.sas.upenn.edu/pennsound/authors/DiPalma/4-2-12/

to the front. Obviously change the file directories to match the recording you are
posting. Now, instead of having to type every entry completely, you can quickly and
efficiently build the list. The only work for the recordings at this point would be to
change the names of the track titles, and reference the files in iTunes to set the
correct track lengths.

Now you can add the complete reading to the page. Close the ordered list, and
open an unordered list (<ul>). Use the same format for the HTML with the single
item.

<li>complete reading (1:04:02): <a
href="http://media.sas.upenn.edu/pennsound/authors/DiPalma/DiPalma-
Ray_Complete-Reading KWH-UPenn_4-2-12.mp3">MP3</a></li>

Two things to remember:

1. Track titles are either “complete reading” or “complete recording”. It’s your
discretion which to use—if a track is missing part of it (generally this
happens when a cassette is flipped to continue a recording), then use
complete recording. If the entire reading is present, use “complete reading”.

2. Our standard is to use lowercase “complete reading,” however, older pages



may use capital letters. Once again, follow the format of the page as it
currently exists.

Finally we have the video recording. Videos actually require little effort on your
part to post, but it is important that you do it correctly.

Navigate to the file’s location in the media_root folder of the media server. Click
the link on the right, this should take you to the video’s page on the media server.
The resulting page will look like this:

Media Manager

Watch

‘You are watching Ray DiPalma -- Reading at the Kelly Writers House, University of Pennsylvania, April 2, 2012.

Il = ooor @ o400 [l | o il
Embed
Select player dimensions and then copy and paste the embed code from the box. The code changes based on your selection.

_Original: 720 x 504 [#] orCustom: [ |x[___|
id="

At the bottom you can see the embed code. Use the “Medium” setting from the
drop box, then copy the code in the box. Paste it in your HTML editor (if it is placed
after a list, add a <br> tag to insert an extra break.

The text will appear on one line. I like to break the code up with the “enter” key to
make the code manageable in a single window. Break the text after closing
brackets—I make it look like:

<object classid="clsid:D27CDBGE-AEGD-11cf-06B8-444553540000" width="480" height="344"><param name="movie" value="http://media.sas.upenn.edu/static/player. swf" ,f-,\

<paran name="flashvars" value="file=128183&config=http://media.sas.upenn.edu/static/player.xml" /><param name="allowfullscreen" value="true" />

<object data="http://media.sas.upenn.edu/static/player. swf" width="480" height="344"><param name="flashvars" value="file=128183&config=http://media.sas.upenn.edu/static/player.xml" />
<paran name="al lowfullscreen" value="true" /><p»<a href="http://get.adobe.con/flashplayer/">Install the Flash plugin</a> to watch this video.</p></object></object>

This code will embed the video on a page, but the preview picture must be set
manually.

To create a preview image, watch the video and skip through to find an



appropriate image from the video. This is usually a title if it is a cinematic work, or
a visual of the reader from some point in the video. Take a screenshot (Alt+Print
Screen on PC, 3 +Shift+3 on Mac). Open the screenshot in an image editor and
crop to create an image that is just the video image. Save the file, and name it as
the video’s file number on the media server (you can find this in the URL of the
video’s page—every media_root entry will have a URL such as
http://media.sas.upenn.edu/file/128183. Those last six digits are the file number.

Once the screenshot is named, upload it to the Preview Images folder on the
web_root section of the Media Server:

https://media.sas.upenn.edu/?directory id=14379

Now go back to the video’s embed code. There are two places that list
http://media.sas.upenn.edu/static/player.xml”

<object classid="clsid:D27(DBE-AEGD-11cf-96B8-444553540000" width="480" height="344"><param name="movie" value="http://media.sas.upenn.edu/static/player.swf" ,f>\

<paran name="flashvars" value="f{le=128183kconfighttp://medla. sas. upenn.edu/static/player.xnl” /><param name="allowfullscreen” value="true" />

<object data="http://nedia.sas.upenn, edu/static/player ST WLGTI= 20" neLghre TA2 > cparan nane="flashvars” value="file=128183%configFELp://MeaLa. 505 .JDENN. eU/ STAEIC/pLOyer. XL |f>
<paran name="allowfullscreen” value="true" /><p><a href="http://get.adobe.con/flashplayer/">Install the Flash plugin</c> to watch this video.</p></object></object>

In between the xml and the quotation mark, enter the following code:

&image=http://media.sas.upenn.edu/pennsound/misc/Images/Previews/12818
3.png

Use the appropriate link to the image you want to embed. It is important that:
1. Youinsert the exact same text in both spots
2. Do not add quotation marks after the equal sign, and make sure that the

code is placed BETWEEN the xml and the quotation mark.

After the video place two breaks (<br><br>) to space the video appropriately on
the page.

Now if you save the HTML and reload the page on PennSound, you should see the
video player with the embed image.

Remember that not every posting will have all of these parts, so use the sections
that are applicable to the recordings you are posting.

5.6: NewAtPennSound Sidebar


https://media.sas.upenn.edu/?directory_id=14379
http://media.sas.upenn.edu/file/128183

Once the recording is posted on the webpage, it’s time to update the
“NewAtPennSound” sidebar on the front page. This is a fairly easy process. First,
go to the main PennSound directory on the Writing Server, and find the “source”
directory. There you will see newatpennsound.html. Open it and you will see an
unordered list. Add your recording to the top of the entries (follow the current
format on the list), and title the link in the format of similar posts. Generally this is:
Author Name: Location, Year

If the page is new, then list:

Author Name: New Author Page

or,

Series Name: New Series Page

Congratulations! You've completed the process of posting on PennSound!



Chapter 6: Miscellaneous

6.1: Also of Interest

Some links to other material are occasionally placed on PennSound at the bottom
of a page under the title “Also of Interest”. These are usually articles (often from
Jacket2 or the EPC) or series on PennSound that the author runs.

The phrase “Also of Interest” is placed in between <h2> tags, and the listings are
placed in an unordered (<ul>) list. Once again, this is always at the bottom of a
page, but above the copyright notice (These recordings are made available...).

6.2: Permissions

You may on occasion have to get permissions from an author before posting a
recording on the site. If unsure of whether you need permissions, ask Mike, Al, or
Charles. They can also give you email addresses to contact the authors. When
requesting permissions, use the following forms:

For aliving author:

Dear ---

| am writing on behalf of Charles Bernstein and Al Filreis about an archival
project at the University of Pennsylvania, in conjunction with Kelly Writers
House and the Center for Program in Contemporary Writing. The project is
called PennSound -- an online archive of MP3 (high quality and
downloadable) sound files of poets readings, with permission of the authors,
and including bibliographic information and useful file names.

http://writing.upenn.edu/pennsound

We would like to make your reading at

available on PennSound.

All material at PennSound will be available, free, for noncommercial and
educational use. (C) remains with the author and this will be embedded into
thefileitself aswell as posted on our web site.



We are writing now to ask your permission. Please reply by email. We will
not proceed unless we hear from you.

Thanks!

For estates:

locate person responsible for estate at
http://tyler.hrc.utexas.edu/index.cfm

Dear ---

| am writing on behalf of Charles Bernstein and Al Filreis about an archival
project at the University of Pennsylvania, in conjunction with Kelly Writers
House and the Center for Program in Contemporary Writing. The project is
called PennSound -- an online archive of MP3 (high quality, downloadable)
sound files of poets' readings, with permission of the authors, and including
bibliographic information and useful file names.

http://writing.upenn.edu/pennsound
We would like to make the reading of

at / when

available on PennSound.

All material at PennSound will be available, free, for noncommercial and
educational use. (C) remains with the estate and this will be embedded into
thefileitself aswell as posted on our web site.

We are writing now to ask your permission. Please reply by email. We will
not proceed unless we hear from you.

Thanks!
Once you have obtained the author’s permission, you need to file it online. Copy all

email text into a word document. Use Fetch/Filezilla in order to connect to the
Writing Server. Navigate to x/protected /permissions


http://tyler.hrc.utexas.edu/index.cfm%20

Create new directories as needed to alphabetically file the permissions. For both
programs, you can simply drag the document into the application’s window once
you are in the appropriate directory in order to start uploading.

6.3: Converting .html to .php

When PennSound was started, we used .html as the file extension for our pages.
Several years ago, however, we switched to .php. Many pages are converted, but
we are still converting .html files as we come across them, so it is important that
you know the process.

To start, create the new Author.php page, and using your HTML editor, copy and
paste the body of the page (all of the recordings) from the .html page to the .php

page.

Next, open up Text Wrangler (note to PC Users, this is easier with MACs, so use
one of the office computers for this step). Click the box in the bottom left corner of
the file browser that says:

Show items starting with “.”
Navigate up the file directory one level to the writing directory. At the top of the
listings, you should see a file named .htaccess. Open it and you will see a list of the

HTML redirections for the Writing Server. Scroll to the bottom of the pennsound
section and type the following:

Redirect 301 /pennsound/x/Rawlings.html http://writing.upenn.edu/pennsound/x/Rawlings.php

Substitute the appropriate filenames. Save and voila! Now when you go to the
html page, it should automatically redirect to the .php page.

Finally, open terminal and connect to the pennsound directory. Use the cd x
command to move to the x directory. Then type to following command:

mv Author.html deleted/

This will delete the .html page from the Writing Server, leaving only the PHP page.



Protocol Cheat Sheet

ofile names:

keep as short as possible!

NEVER use appostraphes or accent marks or '&' sign!
lastname-firstname_track-number_title_place/series_date.mp3

Note: hyphens within fields, underlines between fields.

album/cd name can replace place for compilations (Live at Ear, Dial-a-Poem, etc).
when using cut numbers: put them after title in most cases, or in cases of an
album-name, after the album name, eg:

series names (Philly-Talks) should also be included in file name, after title and
before place-but check on this first to establish best nickname and whether we
need series and place names
Bernstein-Charles_13_from-Dark-City_1-4-92_Live@Ear.mp3
Palmer-Michael__01_Letters-to-Zanzotto_Exact-Change_1994.mp3

note: put the track number immediately after the name; this will keep numeric
order at least within a set.

note: for University of Pennsylvania - UPenn

note: for very long poem names: abbreviate: keep to no more than a three or
four words

note: use normal title capitalization: lower case for articles and prepositions
information.

«ID3 tags:

USE I-Tunes only to encode ID3 info; audacity does not seal the ID3 data.
Check after uploading

Artist's Field: name of poet

Name [Title] field: Title of poem or series

Album field: place and date: give full info for place, eg Segue Series, Ear Inn, NY;
June 1, 1999

Track numbers: If there are numbered tracks, be sure to enter the track numbers
in the ID3, eg 3 of 8, 4 of 8, etc.

Year: give year of recording

Genre: PennSound

Comment field: © notice - which should be simply

© year-of-digital file author/estate. Distributed by PennSound
(http:///writing.upenn.edu/pennsound)

*MP3 technical specs:

in general, convert to MP3 in the MONO mode, since very few of our tapes have
any need for stereo, and this will keep the size much smaller.

MP3s must have a sample rate of 44.1 kHz to play correctly in the Flash player. In -
Tunes, go to edit/preference/advanced/importing/custom.

bit rate: The most common bit rate for stereo MP3 files is 128 kbps. 128 is just fine



and reputed to do justice to CD fidelity. Unless your recordings have been done on
very expensive microphones in studio conditions there is not much sense in using
a higher bit rate.Most voice recordings need only be offered in mono. One
microphone : One channel. Only stereo produced pieces need to be presented in
stere. For I-Tunes, set the mono at a high bit rate so you get max quality for the
one channel: you need to set in Edit/Preferences/Advanced/importing: use
CUSTOM and pick stereo 256 which will translated into mono of 128.

Video Protocols:

In order to stream, videos must be Quicktime, MPEG 4, or Flash videos. The file
name extensions for these formats are:

+  .mov
« .mp4
« .m4a
o flv

For Quicktime and MPEG 4 videos, the following codecs must be used: For video,
use H.264 compression. For sound, use AAC compression.

While not necessary in order to stream properly, we prefer that you use:
4:3 Standard Aspect Ratio

Frame Rate: 30 fps

Size Dimensions: 640 x 480

A video tutorial on how to prepare content for PennSound can be found here:

https://www.sas.upenn.edu/computing/mms/media server/tutorials



https://www.sas.upenn.edu/computing/mms/media_server/tutorials

Terminal Command Cheat Sheet

Connect to the Writing Server
ssh login@writing.upenn.edu
PennSound shortcut
pennsound
List items in the directory
Is -1
Change Directory
cd x

(Or whatever directory you want to change to, x is the only directory you’ll
really use in terminal)
Create a new PHP page
cp Template.php Author.php
Set Access Controls
chmod 664 Author.php
Delete a page
mv Author.html deleted/
Exit

exit



First Assignment Exercise

Now that you've learned how to work for PennSound, it’s time for your first
assignment. Explore the website and find a full reading that has not been
segmented.

Download the file, segment it, tag and name the tracks, upload to the server, and
post them on the page! When you're done, before you post on the front page,
contact either Mike Hennessey (hennessey.michael@gmail.com) or Jeff Boruszak
(Jeffrey.boruszak@gmail.com) and have them look at the page to give you an OK.



mailto:Jeffrey.boruszak@gmail.com
mailto:hennessey.michael@gmail.com

	Chapter 1: Required Programs
	Chapter 2: Audio on PennSound
	Chapter 3: Video on PennSound
	Chapter 4: Using the Media Server
	Chapter 5: Using the Writing Server
	Chapter 6: Miscellaneous
	Protocol Cheat Sheet
	Terminal Command Cheat Sheet
	First Assignment Exercise
	Chapter 1: Required Programs
	Audacity
	Windows
	Mac OS X

	Text Wrangler/jEdit
	Fetch/Filezilla
	SecureCRT
	Handbrake
	iTunes

	Chapter 2: Audio on PennSound
	2.1: Audio Standards
	2.2: Configuring Audacity 
	2.3: Digitizing Cassettes
	2.4: Ripping Audio from Video Files
	2.5: Segmenting Audio
	2.6: Setting Metadata
	2.7: Naming Files

	Chapter 3: Video on PennSound
	3.1: Video Standards
	3.2: Downloading a video from external sites
	3.3: Using Handbrake
	3.4: Using Final Cut Express

	Chapter 4: Using the Media Server
	4.1: Introducing the Media Server
	4.2 Uploading Content
	4.3 Editing Content on the Media Server

	Chapter 5: Using the Writing Server
	5.1: Introducing the Writing Server
	5.2: How to Create a Page
	5.3: How to use HTML
	5.4 Editing a Page – New Page
	5.5: Editing a Page - Existing Pages
	5.6: NewAtPennSound Sidebar
	Chapter 6: Miscellaneous
	6.1: Also of Interest
	6.2: Permissions
	6.3: Converting .html to .php

	Terminal Command Cheat Sheet
	First Assignment Exercise

